Camino is no longer being developed. Learn more.

Managing Downloads

Getting those great new files from the web to your Mac.

Managing Downloads


Downloading files or software

The Downloads window offers an efficient way for users to monitor and control their downloads. You can access a list of downloaded files, pause and resume downloads, and even have quick access to recently downloaded files. To open the Downloads window, you can use the keyboard shortcut ⌘⇧D or select Downloads from the Window menu. If the Downloads window is already open but not the active window, ⌘⇧D will focus the Downloads window.

Open Downloaded Files preference If you download a disk image file (or a ZIP or SIT file), Camino can automatically decompress it; certain media files, for example RealMedia, can also launch the appropriate media player application once downloaded. To enable this, choose Preferences… from the Camino application menu and click on the Downloads pane. Here you can set the Open downloaded files preference.

While convenient, enabling this feature makes your computer vulnerable to damaging programs.

Pausing and resuming downloads

Resume download Pause download Camino now includes a feature to pause and resume downloads. Using this, you can pause your download to save bandwidth and then resume it when you’re ready to finish.

Downloads can only be paused and resumed within the same browsing session; you cannot pause a download, quit Camino, and then resume a download the next time you launch Camino. In addition, not all servers support resuming paused downloads.

Clearing the downloads list

As you download items from websites, they appear in the Downloads window. Camino offers several ways to control how long items remain in the list of downloads. In the Downloads preference pane, the Remove successful downloads preference determines whether Camino removes downloads from the list when they finish, when Camino quits, or manually.

If Camino is set to remove successful downloads manually, use the items in the toolbar of the Downloads window to clear the entire list or remove individual downloads.

Clean Up downloads To clear the list of downloaded files, click on the Downloads window to make it active, use the ⌘⇧D keyboard shortcut, or choose Downloads from the Window menu. Then click the Clean Up button in the toolbar. Cleaning up the Downloads window does not remove items that are currently being downloaded, nor does it delete already-downloaded files from your hard drive.

Remove download from list Alternatively, you can remove indivdual downloads from the Downloads window’s list using the Remove button or by selecting an item in the list and pressing the Delete key.

Selecting where downloaded files are saved

When you download a file, Camino automatically saves it in the location specified in the Downloads pane of the Camino Preferences. Camino will download files to your Desktop by default, but you can change the location.

Choose your download location preference

To change the download location, choose Preferences… from the Camino application menu and select the Downloads preference pane. Next to the text Save downloaded files to, there is a drop-down menu that allows you to choose where downloads are saved.

Note: This changes your download folder location system-wide and will affect other browsers that use the system-wide download folder setting.

Canceling a download

Cancel download icon If you accidentally begin to download a file, you might want to cancel the download. To do this, simply click the Cancel button in the toolbar of the Downloads window to cancel the selected download.

Opening a downloaded file

Open downloaded file from the window When a download has completed, you might want a way to easily open the file (if you haven’t set Camino to open completed downloads automatically). Select one or more downloaded files (or use the ⌘A keyboard shortcut to select all downloads). Then click the Open button in the toolbar of the Downloads window to open the selected downloaded file, or use ⌘↓ keyboard shortcut. You can also drag a downloaded file from the Downloads window to any application’s icon to open the file in that application.

Revealing a downloaded file

Reveal downloaded files When a download has completed and you would like to see the file in the Finder, click the Reveal button in the toolbar of the Downloads window. This will open a Finder window with the download selected.

Deleting a downloaded file

Delete downloaded files When you are finished working with a file that Camino has downloaded, you can move that file to the Trash from the Downloads window, too.

To do so, first add the Trash button to the toolbar in the Downloads window. With the Downloads window active, choose Customize Toolbar… from the View menu. In the customization sheet that appears, drag the Trash button up over the toolbar and release the mouse to drop the item on the toolbar, and then click the Done button to dismiss the customization sheet.

Now select the file you want to delete from the Downloads list and click the Trash button. Camino will move the file to the Trash.

Other Documents

If there are any questions, tutorials, or preferences that would be helpful if they were explained in these pages, don’t hesitate to contact us, and we will add them as necessary.